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1. General 

1.1. Can you explain the concept briefly on how the Ahsay software works? 
The Ahsay Online Backup Suite consists of 3 main modules: 
1. The client software – Ahsay Online Backup Manager (AhsayOBM) 
2. The server software – Ahsay Offsite Backup Server (AhsayOBS) 
3. The replication server – Ahsay Replication Server (AhsayRPS) 
 
AhsayOBM is the client side program which uploads the selected files to the Backup 
server and looks after scheduled backup jobs. It also provides a user-interface for 
configurations of the desired backup sets. AhsayOBM supports a number of operating 
systems, e.g. Windows 2000, XP, 2003, Linux, Mac OS X, etc. And apart from files 
backups, AhsayOBM can backup a range of applications such as MS Exchange, MS 
SQL, Oracle, MySQL, Lotus Domino, etc.  
 
AhsayOBS is the server side program which can serve and store backup data from 
multiple AhsayOBMs/backup accounts. It has a web-based Management Console for 
system administrators to manage the Backup Server, such as configuring system 
parameters, administering the backup accounts, viewing backup statistics and 
reports, etc. Users can also logon to this Management Console to manage their own 
backup account or restore their own backup data. AhsayOBS supports Windows, 
Linux and Mac OS platforms. 
 
AhsayRPS is another piece of server software running on a separate machine which 
provides close to real-time backup for multiple AhsayOBSs. Thus even if one of the 
AhsayOBS fails, the AhsayRPS still has a copy of the backup data.   
 
The relationships of the Ahsay Online Backup Suite are depicted in the diagram 
below. 
 

^Back to top
A

A

(June 16, 2006)
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2. Ahsay Online Backup Manager (AhsayOBM) 

2.1. Can we customize the AhsayOBM? How can we change the name of the 
software, configuration default, and auto-logon? 
Of course it is possible. You can refer to our Administrator's Guide as well as our 
Partner Portal for the details.  
 
^Back to top

2.2. What is the recommended bandwidth? 
It really depends on the kind of data to be backed up, e.g. for personal file backups, 
the daily data transfer should be limited, while MS Exchange backup could be 
significant. You may want to use the following white paper as a reference: 
http://www.ahsay.com/en/doc/white-paper-backup-speed.pdf.

^Back to top

2.3. How do I run AhsayOBM with Microsoft ISA 2004? 
To connect AhsayOBM to AhsayOBS through Microsoft ISA Server, please do the 
following to enable [Web Proxy] service on the ISA Server: 
1. Open [Start] -> [Programs] -> [Microsoft ISA Server] -> [ISA Server 
Management] 
2. On the left panel, select [Microsoft Internet Security and Acceleration Server] -> 
[SERVER] -> [Configuration] -> [Networks] 
3. On the top menu, select [Action] -> [New] -> [Network]. Enter a [Network Name] 
(e.g internal) and define the IP address range for your internal network (e.g. 
192.168.1.0 - 192.168.1.255) 
4. Double click the new network that should now be added to on the bottom panel 
5. Select the [Web Proxy] tab  
6. Check both [Enable Web Proxy clients] and [Enable HTTP] checkboxes and choose 
a [HTTP port] for the web proxy service 
7. (Optional) Press the [Authentication] button, check the [Basic] checkbox and the 
[Require all users to authenticate] checkboxes if you want to enable and enforce 
proxy authentication 
8. Press the [OK] button to make the changes and press the [Apply] button to apply 
the changes 
 
9. Open [Ahsay Online Backup Manager] from the system tray and press the 
[Options] button 
10. In the [Proxy Seting] section, select the [Proxy] radio button 
11. Enter the hostname/IP address of the ISA server in the [Proxy Address] text field 
and the TCP port for web proxy service on your ISA Server in the [Port] text field 
12. Press the [OK] button to connect to the server 
 
If you run into any problems connecting to the AhsayOBS from AhsayOBM using ISA 
Server, please do the following to check if your request is being blocked: 
1. On the left panel of [ISA Server Management], select [Microsoft Internet Security 
and Acceleration Server] -> [SERVER] -> [Monitoring]  
2. Then select the [Logging] tab that appears on the right panel3. Click the [Edit 
Filter] link and create a filter with the following values 
[Log Record Type] equals [Web Proxy Filter] 
[Destination IP] equals [The IP address of Ahsay Offsite Backup Server] 
4. Press the [Start Query] button 
5. Open [Ahsay Online Backup Manager] again and try connecting to the AhsayOBS 
using the same procedure above.  
Check if there are any errors generated in the log table. 
 
^Back to top

http://www.ahsay.com/en/doc/white-paper-backup-speed.pdf
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2.4. How do I install AhsayOBM on FreeBSD? 
You can either run AhsayOBM on a Linux version of Sun Java JDK (performance 
might not be optimized) or on a FreeBSD native Java SDK. 
 
For the Linux version of Sun Java JDK option you need to: 
1. Install Linux binary compatible port to the FreeBSD machine 
2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD 
machine 
3. Create a symbolic link from $OBM_HOME/jvm to $JAVA_HOME (installed in 
previous step) 
4. Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup 
5. Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler 
 
For the FreeBSD native Java SDK option you need to: 
1. Install Linux binary compatible port to the FreeBSD machine 
2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD 
machine 
3. Compile the FreeBSD native Java 1.4.2 SDK using the JDK compiler installed in 
the previous step 
4. Install the FreeBSD native Java 1.4.2 SDK onto the FreeBSD machine 
5. Create a symbolic link from $OBM_HOME/jvm to $JAVA_HOME (installed in 
previous step) 
6. Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup 
7. Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler  
 
^Back to top

2.5. How do I install AhsayOBM on SCO Unix? 
Please do the followings to install AhsayOBM on SCO: 
1. Install Java 1.4.x or above onto your SCO Unix box 
2. Download obm-linux.tar.gz and expand it to $OBM_HOME (e.g. /usr/local/obm) 
3. Delete $OBM_HOME/jvm and create a symbolic link from $OBM_HOME/jvm to the 
SCO Unix Java VM 
4. Run $OBM_HOME/bin/BackupManager.sh to setup your backup set (or run 
$OBM_HOME/bin/Configurator.sh if you are under command line mode. Then use the 
AhsayOBS Management Console to setup your backup sources and other settings) 
5. Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup 
6. Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler 
 
^Back to top

2.6. How do I install AhsayOBM on AIX? 
Please do the followings to install AhsayOBM on AIX: 
1. Install Java 1.3.x or above (Java 1.4.2 or above recommended) onto your AIX box 
2. Download obm-linux.tar.gz and expand it to $OBM_HOME (e.g. /usr/local/obm) 
3. Delete $OBM_HOME/jvm and create a symbolic link from $OBM_HOME/jvm to the 
AIX Java VM 
4. Run $OBM_HOME/bin/BackupManager.sh to setup your backup set (or run 
$OBM_HOME/bin/Configurator.sh if you are under command line mode. Then use the 
web interface to setup your backup sources and other settings) 
5. Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup 
6. Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler 
 
^Back to top

2.7. The Windows version of AhsayOBM installer hangs, what could be the 
problem? 
There are a few things that might cause errors during or after executing the self-
extractor.  First of all, make sure that there is enough disk space on the target 
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system.  Next, make sure that you do not have any anti virus software or 
pcanywhere running as this is known to cause problems with InstallAnywhere 
installers. There are also problems with InstallAnywhere installers and Dell 
OpenManager. If OpenManager is installed on the target system, make sure to 
disable it prior to executing the install. 
 
The last thing would be to try turning your hardware acceleration display setting to 
off. There are known issue with certain versions of Java running against certain video 
cards.    
 
Also, if you are transferring this file from one machine to another, make sure that 
the file size is valid and you are transferring the file in binary mode. 
 
Also, this might be a Java only problem. 
 
Please try running any of the Swing demos that come with the Java runtime in 1.4.X 
and see if it hangs on Windows. Some knowledge base on the web suggested that 
DirectX needs to be updated to at least 8.1 to correct the problem. Most machines 
that have problems with this have DirectX 7.0 installed. (You can use the “dxdiag” 
command to find out the directX version) 
 
Also try the following to fix video card issues: 
The following will pass properties to the installer's VM: 
In Advanced Designer, Project->Config->Additional Arguments, set that to  
"-Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true" without the quotes. 
 
You'll need to set the following lax property in your LaunchAnywhere for your 
application's JVM:  
lax.nl.java.option.additional=-Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true 
 
Add the same line to the uninstaller lax file, using a modify file action in your 
installer in post-install. 
 
Those 2 options are Sun recommended workarounds for certain video card issues. 
 
^Back to top

2.8. The Installer doesn’t seem to work. How can I manually install AhsayOBM 
on Windows? 
Try manually installing AhsayOBM by zipping the program directory (e.g. C:\Program 
Files\AhsayOBM) on another machine with AhsayOBM installed and do the followings 
on the target machine: 
1. Create the directory C:\Program Files\AhsayOBM 
2. Unzip the AhsayOBM program directory archive to C:\Program Files\AhsayOBM 
3. Run C:\Program Files\AhsayOBM\bin\install.bat 
4. Run C:\Program Files\AhsayOBM\bin\Install-Scheduler.bat 
 
^Back to top

2.9. When we run the installer for Mac, the program starts and then after a few 
seconds just quits. What can we do? 
Try manually installing AhsayOBM on your Mac with following instructions: 
1. Download http://download.ahsay.com/support/obm50-mac.zip
2. Expand obm50-mac.zip into /Applications/AhsayOBM 
3. Run "chmod -R 755 /Applications/AhsayOBM" using Terminal 
4. Double-click the “Online Backup Manager” icon in /Applications/AhsayOBM folder 
 
^Back to top

http://download.ahsay.com/support/obm50-mac.zip
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2.10. Are there any command line tools for AhsayOBM? 
Yes, there are a set of scripts in [AhsayOBM Program Home]\bin and they are 
described below: 
 
Windows: 
- Decrypt.bat: decrypts the specified backup files 
- install.bat: installs the AhsayOBM icon to the System Tray and registers the Online 
Backup Scheduler as a service 
- Install-Scheduler.bat: registers the Online Backup Scheduler as a service 
- RegisterVSS.bat: re-registers Microsoft’s Volume Shadow Copy service DLLs 
- Remove-Scheduler.bat: unregisters the Online Backup Scheduler service 
- Restore.bat: restores the specified snapshot of the backup set to the specified 
location 
- RunBackupSet.bat: runs the specified backup set 
- RunOBM.bat: launches the Online Backup Manager user interface 
- Run-Scheduler.bat: starts the Online Backup Scheduler service 
- SeedLoad.bat: runs seed load for the specified backup set to the specified location 
- Uninstall.bat: removes the AhsayOBM icon from the System Tray and unregisters 
the Online Backup Scheduler service 
 
Linux: 
- BackupManager.sh: launches the Online Backup Manager user interface 
- Configurator.sh: configures client parameters such as Backup Server address, 
username/password, encrypting key, etc. 
- Decrypt.sh: decrypts the specified backup files 
- Restore.sh: restores the specified snapshot of the backup set to the specified 
location 
- RunBackupSet.sh: runs the specified backup set 
- Scheduler.sh: starts the Online Backup Scheduler service 
- SeedLoad.sh: runs seed load for the specified backup set to the specified location 
- StopScheduler.sh: stops the Online Backup Scheduler service 
* You may have to set some variables in these scripts and more instructions are 
provided. 
 
^Back to top

2.11. How does AhsayOBM detect changes in files? Does it use the Archive bit? 
Some tape backup software resets the Archive bit. Would this affect 
AhsayOBM when backing up the same data? 
AhsayOBM compares timestamps of files on the server with the corresponding copies 
on client machine. Archive bit is not used as it does not detect relocated files. Thus 
tape backup would not affect AhsayOBM.  
 
^Back to top

2.12. Does AhsayOBM copy the same set of files over and over again? 
After the initial upload, subsequent backup jobs will only transfer the modified or 
new data to the Backup server. It depends on the nature of the data, but normally, 
less than 2% of all data is modified.  
 
^Back to top

2.13. Transfer Block Size is 128Kb by default. Is there a rationale behind? 
Backup data is transferred in blocks (instead of file by file) to minimize connection 
negotiation roundtrips. It is not the TCP/IP block size. This setting is optimal for the 
backup operation. 
 
^Back to top
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2.14. How can I backup a huge data set over the Internet? 
If you have a lot of data (e.g. 300GB) to backup to the backup server, it would take 
a considerable amount of time to perform the first full backup through the Internet. 
You can use the Seed Loading Utility to backup your backup set to local hard disk 
(instead of directly to the backup server) and then transport the backup data, using 
a removable hard disk, to your backup service provider. The administrator can then 
load all your backup files from your removable hard disk into your backup account. 
This could save you days (even weeks) of performing your first full backup. And 
since subsequent backups are incremental (only new or updated files will be 
uploaded to the server), the amount of data transfer should be relatively small.  
 
Please refer to the User’s Guide for details on the “Seed Loading Utility”. 
 
^Back to top

2.15. What is the best way to restore a huge data set? 
You can copy the data of the particular backup set on AhsayOBS to a removable 
media, e.g. external harddisk, and ship it to your client. Your client can then use the 
“Decypt Files Tool” in AhsayOBM to restore the backup data on removable media to 
its original format. 
 
^Back to top

2.16. I understand that the files to be backed up are compressed and encrypted 
before uploading to the Backup Server. What is the average compression 
ratio? 
Average compression ratio for text-based file is around 4:1. However, no further 
compression can be made on files that are already in compressed format (e.g. JPG, 
ZIP). In general, you can assume a 2:1 compression ratio when you are backing up a 
file set with variety types. 
 
^Back to top

2.17. Can I change my encrypting key? 
Once set for a Backup Set, the encrypting key cannot be changed. This is necessary 
for the integrity of the Backup Set, making sure that backup data is only encrypted 
by one key. Otherwise, you will have problems remember two encrypting keys when 
you want to restore your files in the future. 
 
You need to recreate your Backup Set if you really want to change your encrypting 
key.  
 
^Back to top

2.18. What kind of encryption employed by AhsayOBM? 
There are two encryptions being performed by AhsayOBM: 
 
1. Encryption of backup data - This is being done by 128-bit symmetric key 
encryption (AES, TripleDES, TwoFish). 256 bit is not available because it requires too 
much CPU and it is not really required (128-bit is what is being used by most banks 
currently) 
 
2. Encryption of backup traffic - This is being done by 1024 bit RSA public key 
encryption. The strength of the encryption depends on the key size you use when 
you generate your CSR before submitting to your CA. 1024 bit is what is being used 
by most CAs. 
 
^Back to top
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2.19. Can the name Ahsay in the OBM software be removed? Can we put in our 
own company name/brand? 
You can do your own branding both AhwayOBS and AhsayOBM. This means that all 
Ahsay reference can be replaced by those of your company, so that your client will 
not know that it is Ahsay Online Backup software.  
 
^Back to top

2.20. How does the “Remove retention files for overlap policy” under Advanced 
Retention Policy work? 
In general, daily snapshots followed by a weekly snapshot or a monthly snapshot, 
etc. will be removed; weekly snapshots followed by a monthly snapshot or a 
quarterly snapshot, etc. will be removed; and so on.  
 
This is illustrated by the following example. 
Assume today is 17Jan06, and the Advanced Retention Policy is as follows:  
- Daily: retain for 7 days 
- Weekly: retain for 4 weeks (the job will be performed on Saturday) 
- Monthly: retain for 3 months (the job will be performed on 1st of each month) 
 
If “Remove overlap policy” is NOT enabled: 
Then a total of 14 snapshots (7+4+3) will be kept on the server accordingly, i.e.:  
(daily) 10Jan06, 11Jan06, 12Jan06, 13Jan06, 14Jan06, 15Jan06, 16Jan06 
(weekly) 24Dec05, 31Dec05, 7Jan06, 14Jan06 
(monthly) 1Nov05, 1Dec05, 1Jan06 
 
If “Remove overlap policy” is enabled: 
Then only the following snapshots are kept: 1Nov05, 1Dec05, 1Jan06, 14Jan06, 
15Jan06, 16Jan06. 
 
Specifically, the weekly policy overrides the daily policy so 10Jan06, 11Jan06, 
12Jan06 and 13Jan06 will be removed. The monthly policy overrides the weekly 
policy, and 24Dec05, 31Dec05 and 7Jan06 will be removed as well. 
 
^Back to top

2.21. What is incremental backup and how does In-File Delta work? 
In an incremental backup, only modified files will be uploaded to the Backup Server.  
 
On the other hand, In-File Delta is applicable to the physical files to be uploaded to 
the Backup Server, does not matter whether it is a MS SQL database file, MS 
Exchange transaction log file or any normal file in a FileBackupSet. Specifically, only 
the changed blocks in comparison the original file on the Backup Server (delta file) 
will be uploaded. 
 
For each modified file, AhsayOBM would determine whether the entire file or only 
delta file should be uploaded. If the entire file is to be uploaded, the old version of 
the file will be moved to the Retention area. Else if only the delta file is to be 
uploaded, the previous delta files will be moved to the Retention area and the Data 
area should contain the original full backup file, checksum file and the latest delta 
file of this file.  
 
^Back to top

2.22. What happens when we do In-File Delta backup on a directory? 
When you do backup, Ahsay Online Backup software will do this: 
1. Check if any files are added, updated or deleted (the calculation of these files are 
based on files having the same filename). 
2. New files will be uploaded to the server in whole. 
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3. Deleted files will be removed from Data area and placed into the Retention area 
on the Backup server. 
4. Updated files will be processed by the In-File delta option (i.e. only changed data 
blocks within the files will be uploaded to the Backup Server) 
 
^Back to top

2.23. Does AhsayOBM have to stop the application when doing online backups? 
AhsayOBM can backup application data while the application is still running. 
Particularly, we have special agents for MS Exchange Server, MS SQL Server, Oracle, 
Lotus Notes and MySQL, which allows these applications to be backed up while they 
are online. With the Volume Shadow Copy feature started from AhsayOBM v5.0, we 
are able to backup other types of applications while they are online. 
 
^Back to top

2.24. What are Off-line backup, Logout backup reminder and Local backup 
features? 
Off-line backup is basically designed for notebook users who are off-line most of the 
time and cannot rely on backup schedule to backup regularly. The backup interval 
allows notebook users to specify the interval that they would like their data to 
backup. If this interval has elapsed, backup will run automatically once this machine 
is online. 
 
Logout backup reminder asks user if they would like to backup if they logout of the 
computer or shutdown their computer. 
 
Local backup allows an extra copy of backup file to be kept on local hard disk when 
running backup. 
 
^Back to top

2.25. What do I have to do in order to backup open files? 
You need to be on AhsayOBM v5.0 or above, as well as support from the underlying 
OS. Windows XP and 2003, by default, come with Volume Shadow Copy, which 
allows backup of open file. For older platforms, e.g. Windows 9x/ME/NT/2000 or 
NetWare, we would recommend adding a third party open file manager option (e.g. 
St. Bernard Open File Manager - http://www.stbernard.com/) which might cost 
around US$100 for each workstation and US$300 for each server if open file backup 
is required. 
 
* Open file option is not required on Linux/Unix/Mac OS X because no files are held 
exclusively open by applications. 
 
^Back to top

2.26. How does Volume Shadow Copy works? 
Please refer to http://technet2.microsoft.com/WindowsServer/en/Library/2b0d2457-
b7d8-42c3-b6c9-59c145b7765f1033.mspx

^Back to top

2.27. How do I remove OBM completely from my Windows machine? 
If you want to completely remove OBM from Windows, you need to: 
- ensure that the OBM installation directory is deleted (sometimes not removed when 
Windows somehow holds some of the files) 
- remove the C:\Documents and Settings\administrator\.obm\ folder (intentionally 
left undeleted, as crucial information of the user and backup sets, such as the 
encryption keys, is stored here) 

http://technet2.microsoft.com/WindowsServer/en/Library/2b0d2457-b7d8-42c3-b6c9-59c145b7765f1033.mspx
http://technet2.microsoft.com/WindowsServer/en/Library/2b0d2457-b7d8-42c3-b6c9-59c145b7765f1033.mspx
http://www.stbernard.com/


committed to the success of your business 
Ahsay Online Backup

General Technical FAQ

Leb Shama Company Limited Page 11 of 19 (June 16, 2006)

^Back to top



committed to the success of your business 
Ahsay Online Backup

General Technical FAQ

Leb Shama Company Limited Page 12 of 19 (June 16, 2006)

3. Ahsay Offline Backup Server (AhsayOBS) 

3.1. What is the recommended hardware and OS (Windows or Linux) for 
AhsayOBS? 
As a rule of thumb, an active backup connection takes roughly 256KB of memory. 
Thus, a 512MB heap size can easily support over 2000 active backup connections. 
The required storage space depends on the expected amount of backup data from 
your users, and it is possible to make use of external storage server. Most processing 
is done on the client side, thus CPU utilization on the AhsayOBS machine shouldn’t 
be intensive. For your reference, in most circumstances, a P4 2.8GHz CPU with 1GB 
of RAM and lots of disk space (2-4TB of disk space) can support up to 500 user. 
 
AhsayOBS runs equally well on Windows and Linux platforms. You may want to go 
for a platform that your system administrators are comfortable with. From the 
operating system point of view, Linux might be more stable and require less 
maintenance.  
 
^Back to top

3.2. What is the recommended bandwidth? 
It really depends on the expected amount of data transfer from your users and the 
performance criteria if any, of course, as well as your budget. For example, if budget 
your users expect a transfer rate of up to 200MB per hour, and you project that 10 of 
such backups will be running in parallel, then your AhsayOBS should have an uplink 
of around 5Mbps in order to support such requirements.  
 
^Back to top

3.3. Is there a limit on the number of clients that an AhsayOBS can support? How 
many clients would you recommend per AhsayOBS? Also, what is the limit 
on file size that AhsayOBS can backup? 
At the application level, there isn’t really a limit on the number of clients that an 
AhsayOBS can support. However, the number of active clients could be limited by 
the hardware. Specifically, each active backup client connection takes around 256KB 
of memory, so the number of active clients is limited by the RAM available. Also, the 
bandwidth available could also place a limit on the number of active clients, as a rule 
of thumb, you can assume a 3:1 compression ratio when backing up files and a 
throughput of 950MB per hour using an ADSL with 256kbps uplink. 
 
Anyhow, from system administration point of view, we would recommend having no 
more than 2000 users on a single server. 
 
There is no limitation on the file size at the application level. Instead this limitation is 
imposed by the underlying operating system. With modern operating system, you 
should have no problem backing up files at a few TB in size (e.g. NTFS has a file size 
limit of 16TB). 
 
^Back to top

3.4. How many users/licenses can I have on one server? 
There is no limit on the maximum number of users. But from system administration 
point of view, we would recommend having no more than 2000 users on a single 
server. 
 
^Back to top
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3.5. The Installer doesn’t seem to be working. Can I manually install AhsayOBS 
on Windows? 
Try manual installing the AhsayOBS by downloading the upgrade pack (obs-win.zip) 
and do the following: 
1. Create the directory C:\Program Files\Ahsay Offsite Backup Server 
2. Unzip obs-win.zip to C:\Program Files\Ahsay Offsite Backup Server 
3. Run C:\Program Files\Ahsay Offsite Backup Server\bin\install-service.bat 
4. Open your browser and point to http://localhost/ (if you cannot see the welcome 
page, please check if port 80 and 443 are available. You can look at the log files 
available in C:\Program Files\Ahsay Offsite Backup Server\logs for more information) 
 
^Back to top

3.6. How do I install AhsayOBS on FreeBSD? 
You can either run AhsayOBS on a Linux version of Sun Java JDK (performance 
might not be optimized) or on a FreeBSD native Java SDK. 
 
For the Linux version of Sun Java JDK option you need to: 
1. Install Linux binary compatible port to the FreeBSD machine 
2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD 
machine 
3. Create a symbolic link from $OBS_HOME/jvm to $JAVA_HOME (installed in 
previous step) 
4. Run $OBS_HOME/bin/startup.sh to startup AhsayOBS 
 
For the FreeBSD native Java SDK option you need to: 
1. Install Linux binary compatible port to the FreeBSD machine 
2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD 
machine 
3. Compile the FreeBSD native Java 1.4.2 SDK using the JDK compiler installed in 
the previous step 
4. Install the FreeBSD native Java 1.4.2 SDK onto the FreeBSD machine 
5. Create a symbolic link from $OBS_HOME/jvm to $JAVA_HOME (installed in 
previous step) 
6. Run $OBS_HOME/bin/startup.sh to startup AhsayOBS 
 
^Back to top

3.7. Ports 80 and 443 are already taken by other applications, what can I do to 
install AhsayOBS? 
AhsayOBS requires port 80 and 443 by default. You will have problems if these ports 
are already taken by other applications.  
 
You have a few options: 
1. Free up port 80 and 443 for AhsayOBS 
2. Configure AhsayOBS to run on other ports (refer to our Administrator's Guide) 
3. Add one more IP to your server with the corresponding port 80 and 443 dedicated 
for AhsayOBS 
 
^Back to top

3.8. My AhsayOBS doesn’t seem to work, is this related to the Microsoft Internet 
Information Server (IIS) running on the same machine?  
The best way to run AhsayOBS and IIS on the same machine is to have IIS and 
AhsayOBS listening on port 80 and 443 of different IP addresses available on the 
same machine (please note that you can bind more than 1 IP address to the same 
network card).  
 
Assumptions: 
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1. The machine has 2 IP addresses, 192.168.1.1 and 192.168.1.2 
2. You want to run IIS on port 80 and 443 of 192.168.1.1 
3. You want to run AhsayOBS on port 80 and 443 of 192.168.1.2 
 
Instructions: 
1. Configure IIS to listen to 192.168.1.1 address (please look at this article, 
http://support.microsoft.com/kb/813368/en-us)

i) Open [Start] -> [Administrative Tools] -> [Internet Information Service (IIS) 
Manager]  
ii) Right click the [(Server Name)] -> [Web Sites] -> [Administration] node and 
select [Properties] 
iii) Open the [Web Site] tab and select [192.168.1.1] from the drop down list 
 
2. Configure AhsayOBS to listen to port 80 and 443 of 192.168.1.2 by taking a look 
section 15.1 and 15.2 of our Administrator's Guide available at 
http://www.ahsay.com/en/doc/aobs-admin-guide.pdf.

3. Stop the [World Wide Web Publishing Service] service from [Start] -> 
[Administrative Tools] -> [Services] 
 
4. Stop the [Ahsay Offsite Backup Server] service from [Start] -> [Administrative 
Tools] -> [Services] 
 
5. Start the [World Wide Web Publishing Service] service from [Start] -> 
[Administrative Tools] -> [Services] 
 
6. Start the [Ahsay Offsite Backup Server] service from [Start] -> [Administrative 
Tools] -> [Services] 
 
Try browsing http://192.168.1.1/ and http://192.168.1.2/ to see if you can different 
welcome pages from IIS and AhsayOBS respectively.  
 
You can also use the "netstat -an" command to check the "LISTEN" status of 
different TCP/IP entries to see if there are port conflicts. 
 
^Back to top

3.9. The communication between AhsayOBM and AhsayOBS secure is employing 
128-bit SSL, is this adequate? 
Under most situations, 128-bit is already more than enough for commercial use (see 
http://www.ahsay.com/en/product/aobs-security.htm). Also, encryption strength 
doesn't rely solely on the number of bits used in the encryption. The choice of a 
random source and random salt are just as important. In addition, the backup data 
is being encrypted and compressed before sending over from AhsayOBM to 
AhsayOBS, which surely enhances the security. 
 
^Back to top

3.10. How is the data privacy being maintained on AhsayOBS? 
All data are encrypted with user's defined encrypting key before they are sent to the 
online backup server. The encrypting key is not stored on AhsayOBS. Without the 
encrypting key, the backup files are useless to anyone. The backup user is the only 
person who can decrypt the backup files to reveal the original content.  
 
^Back to top

3.11. Can we customize the AhsayOBS?  
Of course it is possible. You can refer to our Administrator's Guide the details.  

http://www.ahsay.com/en/product/aobs-security.htm
http://www.ahsay.com/en/doc/aobs-admin-guide.pdf
http://support.microsoft.com/kb/813368/en-us
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^Back to top

3.12. What is the purpose of the Retention area, can I disable it? 
Deleted and modified files in the current backup are moved to the Retention area in 
AhsayOBS and they will stay there as defined by the retention policy of the backup 
set. You can restore those files that are still in the Retention area.  The main purpose 
of the Retention area is to facilitate retrieval of historical snapshots of a backup set. 
 
Note that the data in the Retention area still counts towards your client’s quota and 
it stay there as defined by your client’s retention policy. 
 
Unfortunately, the Retention area cannot be disabled, at its minimum, your client 
can choose to keep deleted files for 1 backup job.  
 
^Back to top

3.13. Is there an example on how the Retention area works? 
Suppose you have 10GB of initial data which grows by 200MB (0.2GB) per day, and 
on each day 100MB (0.1GB) of the data is modified or deleted from the client 
machine. Assume he takes the default retention policy setting, i.e. 7 days. Then, 
 
Day 0: Data = 10G; Retention = 0; Total quota used = 10G; 
Day 1: Data = 10.2G; Retention = 0.1G; Total quota used = 10.3G; 
Day 2: Data = 10.4G; Retention = 0.2G; Total quota used = 10.6G; 
... 
Day 7: Data = 11.4G; Retention = 0.7G; Total quota used = 12.1G; 
Day 8: Data = 11.6G; Retention = 0.7G; Total quota used = 12.3G; 
 (the 0.1G from Day 1 is removed from the Retention area) 
Day 9: Data = 11.8G; Retention = 0.7G; Total quota used = 12.5G; 
 (the 0.1G from Day 2 is removed from the Retention area) 
…and so on 
 
Thus if data is not being modified or deleted frequently, then the size of Retention 
area should be minimal. 

^Back to top

3.14. Unmodified files are not uploaded to AhsayOBS again. If they were uploaded 
90 days ago and the retention area was 90 days, does this mean they get 
removed with the retention area cleanup and are scheduled for backup again 
the next day? 
Only files that have been deleted (or have been updated by a newer version) are 
stored in the Retention Area. All other files stay in the Data Area as the current copy 
and they are not affected by the retention policy. In other words, unmodified files 
will stay on the AhsayOBS forever. 
 
^Back to top

3.15. Can I increase the quota of Trial accounts on my AhsayOBS? 
Trial accounts can only have a maximum of 500MB and they don't count towards 
your paid licenses. It is not possible to have trial accounts with more than 500MB 
quota.  
 
If you want to have a larger quota for potential clients to evaluate the software, you 
will have to create Paid accounts for them. 
 
^Back to top
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3.16. Is there a tool to verify integrity of the backup data on AhsayOBS? 
Ahsay Online backup already has a built-in checksum mechanism. When a file is 
uploaded, the Backup server would verify the checksum before marking it as a 
successfully transferred file. 
 
In addition, there is a weekly "Rebuild User Storage" batch job, configurable under 
[Manage System] -> [Routine Job] in the AhsayOBS Management Console. This 
ensures that all backup files are valid when they are needed for restore. The settings 
are as follows: 
- [Options] 
 > "Verify File Size" - Verify the backup file size with its expected values 
 > "Verify Checksum" - Verify the checksum of backup file with the value saved 
during upload 
 > "Always Verify All Files" - If this option is not checked, checking is only 
performed once for each backup file (i.e. it won't be rechecked every week). This 
would speed up the checking process. 
- [What to do if a corrupted backup file is found] 
 > "Log information only" - Just log it in system log and do nothing 
 > "Move to retention dir" - Back it up in [User Homes]\[User Login]\errFiles and 
remove this file from the Data area 
 > "Delete from system" - Just delete it from the system 
 
Note that all these actions will be logged in [Manage Log] -> [System Log]. 
 
^Back to top

3.17. Is that any documentation on the APIs? 
Please refer to our Administrator’s Guide. 
 
^Back to top
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4. Ahsay Replication Server (AhsayRPS) 

4.1. How does AhsayRPS work? 
AhsayRPS provides close to real-time backup to multiple AhsayOBS’s.   
 
The replication process can be in [UNSYNC], [SYNC] or [LOGGING] mode. To 
understand the meanings of these replication modes, it is important to understand 
how data gets replicated to AhsayRPS from AhsayOBS.  
 
i. Refreshing File – When AhsayOBS module is started up, it first replicates 
AhsayOBS program binaries and configuration files to AhsayRPS in its [Refreshing 
File] mode. No backup data under [System Home] and [User Homes] will be 
replicated to AhsayRPS by this task.  
 
ii. UNSYNC Replication – After the replication module has finished replicating all 
program binaries and configuration files, it will start replicating all files under the 
[System Home] and [User Homes] directories to AhsayRPS. During the execution of 
this task, transaction logging of AhsayOBS is disabled. Backup data write directly 
and only to the backup files.  
 
iii. SYNC Replication – Since it could take hours (or even days) to replicate all 
backup data from AhsayOBS to AhsayRPS, by the time all files under [System Home] 
and [User Homes] are worked through once, some files might have been added to or 
removed from the AhsayOBS resulted from backup jobs ran during the UNSYNC 
mode. AhsayOBS will then go into a SYNC mode, which has the following effects:  
 a. System data generated by AhsayOBS will now be saved to the transaction log 
files instead of to files under the [System Home] directory.  
 b. There will be no changes to all files under the [User Homes] and [System 
Home] directories  
 c. Before leaving the SYNC mode, AhsayOBS replication module will replay all 
transaction logs recorded to its supposed target files in the [User Homes] and 
[System Home] directories.  
 
Upon the completion of these tasks, both AhsayOBS and AhsayRPS will then be 
synchronized. AhsayOBS should have all transaction logs replayed into the [User 
Homes] and [System Home] directories. Although the [User Homes] and [System 
Home] directories on AhsayRPS doesn’t contains the changes after all transaction 
logs has been replayed, synchronization can be easily done by replicating the 
transaction log files over from AhsayOBS to AhsayRPS and replaying these 
transaction logs on AhsayRPS as it has been done on AhsayOBS.  
 
iv. Transaction Logs Replication – In this mode, backup data are written directly to 
the backup files that they are supposed to go to as well as to the transaction log 
files. The transaction log files recorded after the beginning of the SYNC period are 
then transferred and replayed to AhsayRPS. When there are no backup activities and 
all pending transaction log files have been replicated to AhsayRPS, transaction log 
files are replicated to AhsayRPS every 5 minutes (even when it is empty). This will 
ensure that partial records within the transaction log files get replicated to AhsayRPS 
in close to “real” time.  
 
v. Weekly RESYNC – To ensure that the replication server is in full sync with the 
backup server after lots of transaction logs have been applied on the replication 
server, a weekly RESYNC job will run every Sunday at 12:00pm (noon) 
automatically. This involves running “Refreshing Files”, “UNSYNC Replication” and 
“SYNC replication” described above all over again.  
 
^Back to top
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4.2. My replication pair is not working, what can I do? 
Please do the followings: 
1. Check if you can access the AhsayRPS service by running the following command 
on AhsayOBS: “telnet [AhsayRPS hostname] 8444”. If you get “connection refused”, 
then you have problems connecting to the replication service.   
2. Check your firewall settings to see if port 8444 is blocked  
3. Restart the [Contron Panel] -> [Administrative Tools] -> [Services] -> [Ahsay 
Offsite Backup Server] on AhsayOBS and the [Contron Panel] -> [Administrative 
Tools] -> [Services] -> [Ahsay Replication Backup Server] on AhsayRPS 
4. Check if "Enhanced Security Configuration" for the Internet Explorer enabled. If 
so, please disable it from [Contron Panel] -> [Add/Remove Software] 
5. If you are still having problem, contact us at 
http://kb.ahsay.com/index.php?_m=tickets&_a=submit&departmentid=3&step=1

^Back to top

4.3. How much data are being transfer during the RESYNC process? 
The "weekly RESYNC" sends only UNSYNC data and it doesn't send all data again. It 
just makes sure that all transaction logs are replicated with no errors. 
 
In general, the RESYNC operation doesn't send data that exists on the replication 
server already. 
 
^Back to top

4.4. The replication always stops abnormally during the process, what could go 
wrong? 
Please check if you have any antivirus or personal firewall software installed. Kindly 
disable it from scanning Ahsay related data and traffic to see if the problem persists. 
 
^Back to top

4.5. How up-to-date is the data on AhsayRPS? 
When new files are uploaded to the OBS, the transaction log for the OBS is 
amended, and this transaction log will be applied to the replication server when 
either the transaction log is full or 5 minutes has lapsed, which ever is shorter. Thus 
Data in AhsayOBS and AhsayRPS will be out-of-SYNC by at most 5 minutes. 
 
^Back to top

4.6. What is the average speed for replication? 
The followings are the data obtained from the replication speed test conducted using 
two machines (for both AhsayOBS and AhsayRPS) running Intel Xeon 3.2GHz with 
2GB of RAM over a 2M/2M DSL line with both SSL and encryption enabled: 
 
485 04:22:10 PM Replicating 'D:\OBS-Data\system\logfiles\log04b5.alf' (9.9M) 
486 04:22:53 PM Replicating 'D:\OBS-Data\system\logfiles\log04b6.alf' (10M) 
487 04:23:37 PM Replicating 'D:\OBS-Data\system\logfiles\log04b7.alf' (9.8M) 
488 04:24:24 PM Replicating 'D:\OBS-Data\system\logfiles\log04b8.alf' (9.9M) 
489 04:25:08 PM Replicating 'D:\OBS-Data\system\logfiles\log04b9.alf' (9.8M) 
490 04:26:53 PM Replicating 'D:\OBS-Data\system\logfiles\log04ba.alf' (9.9M) 
491 04:27:48 PM Replicating 'D:\OBS-Data\system\logfiles\log04bb.alf' (9.9M) 
 
The followings are the data we obtained from similar test over a 100MBit ethernet: 
 
103   08:11:38 PM   Replicating 'E:\Project\Testing\obs\v50\conf\rpsSend.xml.9' 
(929) 
104  08:11:38 PM  Replicating 
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-linux.tar.gz' (38.5M) 

http://kb.ahsay.com/index.php?_m=tickets&_a=submit&departmentid=3&step=1
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105  08:12:29 PM  Replicating 
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-mac.zip' (12M) 
106  08:12:45 PM  Replicating 
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-netware.zip' (6.7M) 
107  08:12:54 PM  Replicating 
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-solaris.tar.gz' (6.6M) 
108  08:13:02 PM  Replicating 
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-win.exe' (39.5M) 
109  08:13:56 PM  [End] Refreshing File 
 
Total throughput of 837 MB/hour and 2.63 GB/hour for 2M/2M DSL and 100MBit LAN 
ethernet respectively can be reached. If you are not getting close to this speed with 
similar network and machine setup, please check your I/O, network subsystem or 
CPU usage to see if there is a bottleneck. 
 
^Back to top

4.7. Can I use AhsayRPS to replicate/synchronize the files between my servers? 
It is not possible to do real time replication of files from one server to another. The 
replication module is designed for AhsayOBS replication only and it cannot be used 
for generic replication service between multiple servers. 
 
^Back to top

*** End of FAQ *** 
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